
Limitation of Ms-Excel 

 

Excel Spreadsheet 

Microsoft Excel is an electronic spreadsheet. You can use it to organize your data into 

rows and columns. You can also use it to perform mathematical calculations quickly. 

This notes teaches Microsoft Excel basics. Although knowledge of how to navigate in a 

Windows environment is helpful, this tutorial was created for the computer novice. 

This lesson will introduce you to the Excel window. You use the window to interact with 

Excel. To begin this lesson, start Microsoft Excel 2016. The Microsoft Excel window 

appears and your screen looks similar to the one shown here. 
 
 
 
 

 

Feature Maximum limit 

Open workbooks Limited by available memory and system 
resources 

Worksheet size 1,048,576 rows by 16,384 columns 

Column width 255 characters 

Row height 409 points 

Page breaks 1,026 horizontal and vertical 

Total number of characters that a cell can 
contain 

32,767 characters 

Characters in a header or footer 255 

Sheets in a workbook Limited by available memory (default is 3 
sheets) 

Colors in a workbook 16 million colors (32 bit with full access to 24 
bit color spectrum) 

Named views in a workbook Limited by available memory 

Unique cell formats/cell styles 64,000 

Fill styles 256 

Line weight and styles 256 

Unique font types 1,024 global fonts available for use; 512 per 
workbook 

Number formats in a workbook Between 200 and 250, depending on the 
language version of Excel that you have 
installed 

Names in a workbook Limited by available memory 

Windows in a workbook Limited by available memory 

Hyperlinks in a worksheet 66,530 hyperlinks 

Panes in a window 4 

Linked sheets Limited by available memory 

Scenarios Limited by available memory; a summary 
report shows only the first 251 scenarios 

Changing cells in a scenario 32 

Adjustable cells in Solver 200 
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Custom functions Limited by available memory 

Zoom range 10 percent to 400 percent 

Reports Limited by available memory 

Sort references 64 in a single sort; unlimited when using 
sequential sorts 

Undo levels 100 

Fields in a data form 32 

Workbook parameters 255 parameters per workbook 

Items displayed in filter drop-down lists 10,000 

Noncontiguous cells that can be selected 2,147,483,648 cells 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

File  
In Microsoft Word and other Microsoft Office products the File tab is a tab on the Office 
ribbon that gives you access to file functions. For example, from the File tab you can 
access the Open, Save, Close, Properties, and Recent file options. 



 
 
 

The Quick Access Toolbar  

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access 
toolbar gives you with access to commands you frequently use. By default, Save, Undo, 
and Redo appear on the Quick Access toolbar. You can use Save to save your file, 
Undo to roll back an action you have taken, and Redo to reapply an action you have 
rolled back. 

 
Ribbon contains commands organized in three components: 

Tabs: They appear across the top of the Ribbon and contain groups of related 
commands. Home, Insert, Page Layout is the examples of ribbon tabs. 

Groups: They organize related commands; each group name appears below the group 
on the Ribbon. For example, group of commands related to fonts or group of commands 
related to alignment etc. 

Commands: Commands appear within each group as mentioned above. 

 
The Title Bar 

 
Next to the Quick Access toolbar is the Title bar. On the Title bar, Microsoft Excel 
displays the name of the workbook you are currently using. At the top of the Excel 
window, you should see "Microsoft Excel - Book1" or a similar name. 
The Ribbon 

 
 
 
 
 
 
 
 
 
 
 

 
You use commands to tell Microsoft Excel what to do. In Microsoft Excel 2016, you use 
the Ribbon to issue commands. The Ribbon is located near the top of the Excel window, 
below the Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab 
displays several related command groups. Within each group are related command 
buttons. You click buttons to issue commands or to access menus and dialog boxes. 
You may also find a dialog box launcher in the bottom-right corner of a group. When 
you click the dialog box launcher, a dialog box makes additional commands available. 

Quick Access Toolbar 
Tabs 

Name Box Furmula Bar 



 

Workbook: - It is a current open window of excel. It is a collection of work sheet. There 

are three Worksheet in a workbook by default. 

 
Worksheet: -Worksheet is the combination of rows and columns. In one worksheet, 

there are 65,536 (1 to 65,536) rows and 256(A to IV) columns. (1,048,576 rows by 

16,384 columns in 2007/2010/2013/2016) 

 
Row: -Row is the horizontal line of the cells in a worksheet. There are 65,536 rows in a 

single sheet. 

Column: - Column is the vertical line of cells in a worksheet. 

Cells: - It is the rectangular block in a worksheet. it is the meet point of row ad column. 

The Formula Bar 

 
 

If the Formula bar is turned on, the cell address of the cell you are in displays in the 
Name box which is located on the left side of the Formula bar. Cell entries display on 
the right side of the Formula bar. If you do not see the Formula bar in your window, 
perform the following steps: 

 
1. Choose the View tab. 
2. Click Formula Bar in the Show/Hide group. The Formula bar appears. 
Note: The current cell address displays on the left side of the Formula bar. 

 

The Status Bar 
 

The Status bar appears at the very bottom of the Excel window and provides such 
information as the sum, average, minimum, and maximum value of selected numbers. 
You can change what displays on the Status bar by right-clicking on the Status bar and 
selecting the options you want from the Customize Status Bar menu. You click a menu 
item to select it. You click it again to deselect it. A check mark next to an item means 
the item is selected. 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Move around a Worksheet 
By using the arrow keys, you can move around your worksheet. You can use the down 
arrow key to move downward one cell at a time. You can use the up arrow key to move 
upward one cell at a time. You can use the Tab key to move across the page to the 
right, one cell at a time. You can hold down the Shift key and then press the Tab key to 
move to the left, one cell at a time. You can use the right and left arrow keys to move 
right or left one cell at a time. The Page Up and Page Down keys move up and down 
one page at a time. If you hold down the Ctrl key and then press the Home key, you 
move to the beginning of the worksheet. 

The Down Arrow Key 
 Press the down arrow key several times. Note that the cursor moves downward one 
cell at a time. 

The Up Arrow Key 
 Press the up arrow key several times. Note that the cursor moves upward one cell 
at a time. 

The Tab Key 
1. Move to cell A1. 
2. Press the Tab key several times. Note that the cursor moves to the right one cell at 
a time. 

The Right and Left Arrow Keys 
1. Press the right arrow key several times. Note that the cursor moves to the right. 
2. Press the left arrow key several times. Note that the cursor moves to the left. 



 

The Name Box 

You can also use the Name box to go to a specific cell. Just type the cell you want to 
go to in the Name box and then press Enter. 
1. Type B10 in the Name box. 
2. Press Enter. Excel moves to cell B10. 

 

Select Cells 
 

To select cells A1 to E1: 
1. Go to cell A1. 
2. Press the F8 key. This anchors the cursor. 
3. Note that "Extend Selection" appears on the Status bar in the lower-left corner of the 
window. You are in the Extend mode. 
4. Click in cell E7. Excel highlights cells A1 to E7. 
5. Press Esc and click anywhere on the worksheet to clear the highlighting. 

 

Alternative Method: Select Cells by Dragging 
 

You can also select an area by holding down the left mouse button and dragging the 
mouse over the area. In addition, you can select noncontiguous areas of the worksheet 
by doing the following: 

Enter Data 
 

In this section, you will learn how to enter data into your worksheet. First, place the 
cursor in the cell in which you want to start entering data. Type some data, and then 
press Enter. If you need to delete, press the Backspace key to delete one character at 
a time. 

Enter Data 
 

1. Place the cursor in cell A1. 
2. Type IT ZONE. Do not press Enter at this 

time. 
 

Delete Data 
The Backspace key erases one character at 
a time. 
1. Press the Backspace key until Jordan is 
erased. 
2. Press Enter. The name "John" appears in 
cell A1. 

Edit a Cell 
 

After you enter data into a cell, you can edit the data by pressing F2 while you are in 
the cell you wish to edit. 



 

 

Edit a Cell 
Change "IT" to "ZONE." 
1. Move to cell A1. 
2. Press F2. 
3. Press Enter. 

Alternate Method: Editing a Cell by Using the Formula Bar 
You can also edit the cell by using the Formula bar and double click. You change 
"Jones" to "Joker" in the following exercise. 

 
Wrap Text 

When you type text that is too long to fit in the cell, the text overlaps the next cell. If you 
do not want it to overlap the next cell, you can wrap the text. 

Move to cell A2. 
 

1. Type Text too long to fit. 
2. Press Enter. 
4. Return to cell A2. 
5. Choose the Home tab. 
6. Click the Wrap Text button Excel wraps the text in the cell. 

 
Save a File 
1. Click the File button. 
2. Click Save. The Save As dialog box appears. 
3. Go to the directory in which you want to save your file. 
4. Type Lesson1 in the File Name field. 
5. Click Save. Excel saves your file. 

 
Close Excel 

 

1. Click the File tab 
2. Click Close. Excel closes. 
Or directly click on close button of the right side. 

 

Entering Excel Formulas and Formatting Data 

A major strength of Excel is that you can perform mathematical calculations and format 
your data. 

 
Perform Mathematical Calculations 

In Microsoft Excel, you can enter numbers and mathematical formulas into cells. 
Whether you enter a number or a formula, you can reference the cell when you perform 
mathematical calculations such as addition, subtraction, multiplication, or division. 
When entering a mathematical formula, precede the formula with an equal sign. Use 
the following to indicate the type of calculation you wish to perform: 



 

About calculation operators  
 

Operators specify the type of calculation that you want to perform on the elements of a 
formula. Microsoft Excel includes four different types of calculation operators: 
arithmetic, comparison, text, and reference. 

 
Types of operators 

 

Arithmetic operators: - To perform basic mathematical operations such as addition, 
subtraction, or multiplication; combine numbers; and produce numeric results, use the 
following arithmetic operators 

Plus + (Addition) 

Minus - (Subtraction) 

Asterisk * (Multiplication) 

Slash / (Division) 

 

Logical Operator 
 

 

 
 

 

And Operator 
 

Condition 1 Condition 2 Output/Result 

F F F 

F T F 

T F F 

T T T 

 

OR Operator 
 

Condition 1 Condition 2 Output/Result 

F F F 

F T T 

T F T 

T T T 

OR 

IF 

AND 



Relational Operator 
 

Greater than > 

Less than < 

Greater than and Equal to >= 

Less Than and equal to <= 

not equal to <> 

 
 

Addition 
 

1. Give them some number on cell. 
2. Click on formula bar. 
3. Press = 
4. Click on first cell which you want to addition and press + sign than click another cell. 
5. Than press enter. 
Note: Clicking the check mark on the Formula bar is similar to pressing Enter. Excel 
records your entry but does not move to the next cell. 

(Note: Subtraction, Multiplication and Division are like addition. Only change the 

operator.) 

 
 
 

 
AutoSum 

You can use the AutoSum button on the Home tab to 

automatically add a column or row of numbers. When you press the AutoSum button  

, Excel selects the numbers it thinks you want to add. If you then click the check mark 

on the Formula bar or press the Enter key, Excel adds the numbers. If Excel's guess as 

to which numbers you want to add is wrong, you can select the cells you want. 



  

 

What is conditional Formatting?  

Conditional formatting allows you to set rules for cell formatting. If the rules(conditions) 

are met, then the formatting is applied. You can have up to 3 rules 

in a cell. For example, you can set conditional formatting so that a 

cell turns blue, yellow, red, dark etc. if it contains a value 

higher/greater than 12000. 

1. Select the cells to be formatted. 

2. On the Home tab in the styles group click on Conditional 

formatting… 

3. Choose Highlight Cells Rules click on Greater Than (to your 

requirement) 

4. Type 10000 in the formatting dialog box and choose required 

color design. 

5. Click on Ok. 

 
 
 
 
 
 
 
 
 

Align Cell Entries 

When you type text into a cell, by default your entry aligns with the left side of the cell. 
When you type numbers into a cell, by default your entry aligns with the right side of the 
cell. You can change the cell alignment. You can center, left-align, or right-align any cell 
entry. Look at cells A1 to D1. Note that they are aligned with the left side of the cell. 

 

 

Top Align 
 
 

Left Align 

 

Bottom 

Right Align 

 

 

 

 
Center 

Center Align  
Middle Align 

1. Select cells A1 to D1. 
2. Choose the Home tab. 



  
 
 

3. Click the Center button  in the Alignment group. Excel centers each cell's content. 

Left-Align 
1. Select cells A1 to D1. 
2. Choose the Home tab. 

3. Click the Align Text Left  button in the Alignment group. Excel left-aligns each 
cell's content. 

Right-Align 
1. Select cells A1 to D1. Click in cell A1. 
2. Choose the Home tab. 

3. Click the Align Text Right button. Excel right-aligns the cell's content. 
4. Click anywhere on your worksheet to clear the highlighting. 

 
Note: You can also change the alignment of cells with numbers in them by using the 
alignment buttons. 

 
 

New Worksheet 
In Microsoft Excel, each workbook is made up of several worksheets. Each worksheet 
has a tab. By default, a workbook has three sheets and they are named sequentially, 
starting with Sheet1. The name of the worksheet appears on the tab. Before moving to 
the next topic, move to a new worksheet. The exercise that follows shows you how. 

Move to a New Worksheet 
 Click Sheet in the lower-left corner of the screen. Excel moves to Sheet. 

 
Work with Long Text 
Whenever you type text that is too long to fit into a cell, Microsoft Excel attempts to 
display all the text. It left-aligns the text regardless of the alignment you have assigned 
to it, and it borrows space from the blank cells to the right. However, a long text entry 
will never write over cells that already contain entries—instead, the cells that contain 
entries cut off the long text. The following exercise illustrates this. 

 
Change A Column's Width 
You can increase column widths. Increasing the column width enables you to see the 
long text. 



  

 

Change Column Width 
1. Make sure you are in any cell under column A. 
2. Choose the Home tab. 
3. Click the down arrow next to Format in the Cells group. 
4. Click Column Width. The Column Width dialog box 
appears. 
5. Type 55 in the Column Width field. 
6. Click OK. Column A is set to a width of 55. You should 
now be able to see all of the text. 

 
Change a Column Width by Dragging 

 

You can also change the column width with the cursor. 
1. Place the mouse pointer on the line between the B 
and C column headings. The mouse pointer should look like 

the one displayed here , with two arrows. or Double click 
on right heading border for auto fit. 

Absolute Cell Addressing 
 

You make a cell address an absolute cell address by placing a dollar sign in front of the 
row and column identifiers. You can do this automatically by using the F4 key. To 
illustrate: 
1. Move to cell C12. 
2. Type =. 
3. Click cell C9. 
4. Press F4. Dollar signs appear before the C and the 9. 
5. Type +. 
6. Click cell C10. 
7. Press F4. Dollar signs appear before the C 
and the 10. 
8. Type +. 
9. Click cell C11. 
10. Press F4. Dollar signs appear before the C 
and the 11. 
11. Click the check mark on the formula bar. Excel records the formula in cell C12. 

 
Insert and Delete Columns and Rows 
You can insert and delete columns and rows. When you delete a column, you delete 
everything in the column from the top of the worksheet to the bottom of the worksheet. 
When you delete a row, you delete the entire row from left to right. Inserting a column 
or row inserts a completely new column or row. 

Insert and Delete Columns and Rows 

1. Click on column which you want to delete. 

2. Right click on the column and click on delete. 



  

 

To insert a column: 
 

1. Click on A to select column A. 
2. Click the down arrow next to Insert in the Cells group. A menu appears. 
3. Click Insert Sheet Columns. Excel inserts a new column. 
4. Click anywhere on the worksheet to remove your selection. 

 

To insert rows: 
1. Click on 1 and then drag down to 2 to select rows 1 and 2. 
2. Click the down arrow next to Insert in the Cells group. A menu appears. 
3. Click Insert Sheet Rows. Excel inserts two new rows. 
4. Click anywhere on the worksheet to remove your selection. 
Your worksheet should look like the one shown here. 

 
Create Borders 

You can use borders to make entries in your Excel worksheet stand out. You can 
choose from several types of borders. When you press the down arrow next to the 

Border button   , a menu appears. By making the proper selection from the menu,   you 
can place a border on the top, bottom, left, or right side of the selected cells; on all sides; 
or around the outside border. You can have a thick outside border or a border with a 
single-line top and a double-line bottom. Accountants usually place a single underline 
above a final number and a double underline below. The following illustrates: 

Create Borders 
 

1. Select cells where you want to set the borders. 
2. Choose the Home tab. 

3. Click the down arrow next to the Borders button . A menu appears. 
4. Click Top and Double Bottom Border. Excel adds the border you chose to the 
selected cells. 

 
 
 
 
 
 
 
 

Borders Merge and Center 
 
 

 

Merge and Center 
Sometimes, particularly when you give a title to a section of your worksheet, you will 
want to center a piece of text over several columns or rows. The following example 
shows you how. 



  

 

Merge and Center 
 

1. Go to any cell. 
2. Type IT ZONE COMPUTER EDUCATION. 
3. Click the check mark on the Formula bar. 
4. Select cells want to merge. 
5. Choose the Home tab. 
6. Click the Merge and Center       button in the Alignment group. 

Note: To unmerge cells: 
1. Select the cell you want to unmerge. 
2. Choose the Home tab. 
3. Click the down arrow next to the Merge and Center button . A menu appears. 
4. Click Unmerge Cells. Excel unmerges the cells. 

 
Add Background Color 
To make a section of your worksheet stand out, you can add background color to a cell 
or group of cells. 
1. Select cells which you want to color. 
2. Choose the Home tab. 

3. Click the down arrow next to the Fill Color button. 
4. Click the on the any color. 



  
 
 

 

Some Common functions used in excel 

1. Abs(X) 

Returns the absolute value of a number, a number without its sign. 

Use: - =Abs (100-200) 

100 

2. Max (A1:A5) 

Returns the largest value in a set of values. 

10 

40 

30 

20 

Use: - =Max(A1:A5) 

40 

6. Min (A1:A5) 

Returns the smallest value in a set of values. Ignores logical values and text. 

10 

40 

30 

20 

Use: - =Min(A1:A5) 

10 

4. Upper ("Text") 

Converts a text strings in all uppercase text. 

5. Use: - =Upper ("it zone computer") 

IT ZONE COMPUTER 

1. Lower("Text") 
Converts a text strings in all lowercase text. 

Use: - =Lower ("IT ZONECOMPUTER") 

it zone computer 

2. NOW () 

Returns the current date and time formatted as a date and time. 

Use: - =NOW () 

Or, 

Press: - Ctrl+; 

3. Today () 

To show current date only in current sheet. 

Use: - =Today () 



  

 

Format Numbers  
You can format the numbers you enter into Microsoft Excel. For example, you can add 
commas to separate thousands, specify the number of decimal places, place a dollar 
sign in front of a number, or display a 
number as a percent. 

 
Format Numbers 

1. Move to cell B8. 
2. Type 1234567. 

 

Change a decimal to a percent. 

1. Move to cell B9. 
2. Type .35 (note the decimal point). 
3. Click the check mark on the formula bar. 
4. Choose the Home tab. 

5. Click the Percent Style button . Excel turns the decimal to a percent. 

Format worksheet  

3. 
4. 
5. 
6. 

7. 

8. 

Click the check mark on the Formula bar. 
Choose the Home tab. 
Click the down arrow next to the Number Format box. A menu appears. 
Click Number. Excel adds two decimal places to the number you typed. 

Click the Comma Style button . Excel separates thousands with a comma. 

9. 

Click the Accounting Number Format button 
number. 

Click twice on the Increase Decimal button 
decimal places. 

. Excel adds a dollar sign to your 

to change the number format to four 

 
10. Click the Decrease Decimal button 

places. 
if you wish to decrease the number of decimal 



  

1. Move to cell. 
2. Type the word Sum. 
3. Select cells B4 to C4. 
4. Choose the Home tab. 
5. Click the down arrow next to the Borders 

button . 
6. Click Top and Double Bottom Border. 
As you learned in Lesson 2, you can also 

calculate a sum by using the AutoSum button . 

Calculate an Average 

You can use the AVERAGE function to calculate the average of a series of numbers. 

 
 
 
 
 
 
 
 

 
1. Move to cell A6. 
2. Type Average. Press the right arrow key to move to cell B6. 
3. Type =AVERAGE (B1:B3). 
4. Press Enter. The average of cells B1 to B3, which is 21, appears. 

 
Calculate an Average with the AutoSum Button 

In Microsoft Excel, you can use the AutoSum button to calculate an average. 
 

1. Move to cell C6. 
2. Choose the Home tab. 
3. Click the down arrow next to the 

AutoSum button . 

4. Click Average. 
5. Select cells C1 to C3. 
6. Press Enter. The average of cells C1 
to C3, which is 100, appears. 



   

Working with different formulas 

 

Simple Billing system. 
JAMEER STORE  

SN Name of ITEM Quantity Price Amount 

1 Potato 20 35 700 

2 Banana 15 50  

3 Orange 12 120  

4 Mango 5 80  

5 Onion 20 40  

 

Solution 
Amount: - Qty * Rate 
Discount: - Discount will give 10% of the Amount. 
Net Amount: - Amount – Discount 

 
 

Simple Billing system. 
KONZOM STORE 

SN 
Name of 
ITEM 

 
Quantity 

 
Price 

 
Amount 

 
Discount 

 
Net Amount 

1 Potato 20 35    

2 Banana 15 50    

3 Orange 12 120    

4 Mango 5 80    

5 Onion 20 40    

 

Salary Sheet. 
 

Sample of Salary Sheet 

SN 
 
Name 

 
Address 

 
Post 

 
Salary 

 
Bonus 

 
Tax 

Net 
Salary 

1 Dan Mnr Teacher 30000 4500 2400 32100 

2 Raju KTM Manager 40000    

3 Laxman Dhangadhi Police 20000    

4 Birendra Pokhara Supervisor 45000    

5 Anita Ilam Peon 12000    



 

Criteria 

Bonus: - Bonus will give 15% of the Basic Salary. 

Tax: - Tax will give 8% of the Basic Salary. 

 
Solution 

=Basic Salary*15% 

=Basic Salary*8% 

Total: - Salary + Bonus – Tex 

 
Bonus: - if salary is greater than equal to 25000, Bonus will give 15% of the Basic 

Salary. 

-Otherwise bonus will give 10% of the Basic Salary. 

Tax: - Tax will give 5% of the Basic Salary. 

Total: - Salary + Bonus – Tex 
 
Solution 

Bonus: - =if(Salary>25000,Salary*15%, Salary*10%) 

Tax: - Salary*5% 

 
Criteria 

Bonus: - if address is KTM, Bonus will give 20% of the Basic Salary. 

- Otherwise 10% bonus will give others. 

Tax: - If Post is Manager than bonus will give 10% of the salary, other wise 5% bonus 

will give others. 

 
Solution 

Bonus: - =if(Address ="KTM",Salary*20%, Salary*10%) 

Tax: - if(Post ="Manager", Salary*10%,Salary* 5%) 

 
Criteria 

Bonus: - if address is KTM or Post is equal to Manager, Bonus will give 25% of the 

Basic Salary. 

- Otherwise 10% bonus will give others. 

Tax: - If Post is Manager or Salary is less than 25000, Tax will give 10% of the Basic 

Salary. 

- 5% Tax will give others. 

 
Solution 

Bonus: - =if(OR(Address ="KTM",Post= "Manager"), Salary*20%, Salary*10%) 



 

 

Tax: - if(OR(Post ="Manager", Salary<25000),Salary*10%, Salary*5%) 

 
Excel df dflysf] ;'qsf] k|of]u ubf{ Salary, Post, Address etc. sf] 7fpFdf h:tfsf] t]:t} gn]vL ;f]xL Active 
Cell df Click ug]{_ 

 
 

Mark-Sheet 

Criteria 

Total:  Sum of All obtain numbers. 

Result: If student obtain mark is greater than 35 in all subject, pass otherwise Fail. 

PCT: if result is pass, total/number of subject, Otherwise 0. 

Division: if PCT greater than 80, Distinction, if PCT greater than 60, First, if PCT greater 

than 45 than second, if PCT greater than 35 than Third, Otherwise No Division. Remark: 

- if Division is Distinction than Outstanding, If Division is First than Excellent, if Division 

is Second than Well, If Division is Third than Good, otherwise Try Again. 

 

 NAUGAD SECONDARY SCHOOL  

SN Name English Nepali Computer Science Math Total Result PCT Division Remar k 

1 Bikram 84 78 86 87 89       

2 Raju 75 87 87 25 75       

3 Mohan 84 58 65 75 84       

4 Naresh 35 40 45 74 87       

5 Rajan 38 40 65 36 41       

 

 
Solution 

Result: - 

=IF(AND(English>=35,Nepali>=35,Computer>=35,Science>=35,Math>=35),"Pass","F 

ail")       

Percentage: - =IF(Result="Pass",Total/5,0) 

Division: - =IF(PCT>=80,"Distinction",IF(PCT>=60,"First",IF(PCT >=45,"Second", 

IF(PCT>35,"Third", "No Division")))) 

Remark: -=IF (Division="Distinction", "Outstanding" ,IF (Division= 

"First","Excellent",IF(Division="Second","Well",IF(Division ="Third","Good","Try 

Again")))) 
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Grading Mark sheet 
 

Grade: If Percentage greater than 90 then A+, if Percentage Greater than 80 then, 
Grade is A, if Percentage Greater than 70 then, grade B+, if percentage greater than 60 
then , grade B, if percentage greater than 50 then, grade C+, if percentage greater than 
40 then, grade C, if percentage greater than 30, 

 

JAMEER 
SECONDARY 

SCHOOL 

Student Name English Nepali Computer Digital Logic Total Percentage Grade GPA 

Dan 85 98 99 84 366 91.5 A 4 

Raju 68 98 69 48 283 70.75 B+ 3.33 

Dev 88 84 62 45 279 69.75 B 3 

Shanti 69 99 85 89 342 85.5 A- 3.67 

Harish 22 42 12 42 118 29.5 C 2 

 
 

Grade: - if(pct>=90,"A", if(pct>=80,"A-", if(pct>=70,"B+", if(pct>60="B", if(pct>="C+", 
if(pct>=50,"C", if(pct>=40,"D+", if(pct>30,"D",if(pct>20,"E"."F"))))))) 

 

GPA: =Vlookup(Grade, Table area, make absolute ,2,0) 

 
Letter 
Grade 

 
Points 

A 4.00 

A- 3.67 

B+ 3.33 

B 3.00 

C+ 2.67 

C 2.33 

D+ 2.00 

D 1.67 

E 1.00 

F 0.00 
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Electricity Bill 

C_ID C Name Type P Unit C Unit Con-Unit Amount 

1 Raju Po_P 35 456   

2 Sunita Pr_P 653 789   

3 Gita Po_P 485 685   

4 Hari Pr_P 954 1200   

5 Harry Po_P 253 695   

 

 

Conditions and Formula 
 

Unit Consume =Current Unit-Previous Unit 

Amount= 
If Unit consume is less than or equal 20 units, Amount=20, Or 

if Unit consume is Greater than 20 units, Amount is 7.7 for extra Unit, Or 

If Unit consume is Greater than 250 units, Amount is 9.9 for extra Unit. 

Solution 

=if(Con-Unit>250, (Con-Unit-250) *9.9+230*7.7+20,if(Con-Unit>20,(Con-Unit- 

20)*7.7+20,20)) 

 

Telecom Bill 

 
C_ID 

 
C_Name 

 
Type 

Previous 
Call 

Current 
Call 

 
Total Call 

 
Amount 

1 Raju Po_P 35 456   

2 Sunita Pr_P 653 789   

3 Gita Po_P 485 685   

4 Hari Pr_P 954 1200   

5 Harry Po_P 253 695   

 
 

Amount= 

If Total call is less than or equal 100 units, Amount=200, Or 

if Total call is Greater than 100 units, Amount is 2.5 for extra Call, Or 

If Total Call is Greater than 500 Call, Amount is 3.5 for extra Unit. 
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Create Headers and Footers 
 

You can use the Header & Footer button on the Insert tab to create headers and footers. 
A header is text that appears at the top of every page of your printed worksheet. A footer 
is text that appears at the bottom of every page of your printed worksheet. When you 
click the Header & Footer button, the Design context tab appears and Excel changes to 
Page Layout view. A context tab is a tab that only appears when you need it. Page 
Layout view structures your worksheet so that you can easily change the format of your 
document. You usually work in Normal view. 
You can type in your header or footer or you can use predefined headers and footers. 
To find predefined headers and footers, click the Header or Footer button or use the 
Header & Footer Elements group's buttons. When you choose a header or footer by 
clicking the Header or Footer button, Excel centers your choice. The table shown here 
describes each of the Header & Footer Elements group button options. 

 

Header & Footer Elements 

Button Purpose 

Page Number Inserts the page number. 

Number of Pages Inserts the number of pages in the document. 

Current Time Inserts the current time. 

File Path Inserts the path to the document. 

File Name Inserts the file name. 

Sheet Name Inserts the name of the worksheet. 

Picture Enables you to insert a picture. 

 

Both the header and footer areas are divided into three sections: left, right, and center. 
When you choose a Header or Footer from the Header & Footer Elements group, where 
you place your information determines whether it appears on the left, right, or center of 
the printed page. You use the Go to Header and Go to Footer buttons on the Design 
tab to move between the header and footer areas of your worksheet. 

 
. 

 
Insert Headers and Footers 

 

1. Choose the Insert tab. 
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2. Click the Header & Footer button in the Text group. Your worksheet changes to Page 
Layout view and the Design context tab appears. Note that your cursor is located in the 
center section of the header area. 
3. Click the right side of the header area. 
4. Click Page Number in the Header & Footer Elements group. When you print your 
document, Excel will place the page number in the upper-right corner. 
5. Click the left side of the Header area. 
6. Type your name. When you print your document, Excel will place your name in the 
upper-left corner. 
7. Click the Go To Footer button. Excel moves to the footer area. 
8. Click the Footer button. A menu appears. 
9. Click the path to your document. Excel will place the path to your document at the 
bottom of every printed page. 

Return to Normal View 
 

To return to Normal view: 
1. Choose the View tab. 
2. Click the Normal button in the Workbook Views group. 

 
Set Print Options 

 

The simplest way to print is to click the Office button, highlight Print on the menu that 
appears, and then click Quick Print in the Preview and Print the Document pane. Dotted 
lines appear on your screen, and your document prints. The dotted lines indicate the 
right, left, top, and bottom edges of your printed pages. 

 
You click the Print button when you are ready to print. The Print dialog box appears. 
You can choose to print the entire worksheet or specific pages. If you want to print 
specific pages, enter the page numbers in the Form and to fields. You can enter the 
number of copies you want to print in the Number of Copies field. 

 
 

Creating Charts 
In Microsoft Excel, you can represent numbers in a chart. On the Insert tab, you can 
choose from a variety of chart types, including column, line, pie, bar, area, and scatter. 
The basic procedure for creating a chart is the same no matter what type of chart you 
choose. As you change your data, your chart will automatically update. 
You select a chart type by choosing an option from the Insert Tab's Chart group. After 
you choose a chart type, such as column, line, or bar, you choose a chart sub-type. For 
example, after you choose Column Chart, you can choose to have your chart 
represented as a two-dimensional chart, a three-dimensional chart, a cylinder chart, a 
cone chart, or a pyramid chart. There are further sub-types within each of these 
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categories. As you roll your mouse pointer over each option, Excel supplies a brief 
description of each chart sub-type. 
Create a Chart 
To create the column chart shown below, start by creating the worksheet below exactly 
as shown. 

1. Click on insert. 
2. Select the data for chart. 
3. Click on Column, pie, line etc. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

After you have created the worksheet, you are ready to create your chart. 
Apply a Chart Layout 
Context tabs are tabs that only appear when you need them. Called Chart Tools, there 
are three chart context tabs: Design, Layout, and Format. The tabs become available 
when you create a new chart or when you click on a chart. You can use these tabs to 
customize your chart. 
You can determine what your chart displays by choosing a layout. For example, the 
layout you choose determines whether your chart displays a title, where the title 
displays, whether your chart has a legend, where the legend displays, whether the chart 
has axis labels and so on. Excel provides several layouts from which you can choose. 

 

 
Apply a different Chart Design/Type 

 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 
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3. Click the Quick Layout button in the Chart Layout group. A list of chart layouts 
appears. 

4. Click Layout 5. Excel applies the layout to your chart. 

 
 

Add Labels 
When you apply a layout, Excel may create areas where you can insert labels. You use 
labels to give your chart a title or to label your axes. When you applied layout 5, Excel 
created label areas for a title and for the vertical axis. 

Add labels 
Select Chart Title. Click on Chart Title and then place your cursor before the C in Chart 
and hold down the Shift key while you use the right arrow key to highlight the words 
Chart Title. 
2. Type Toy Sales. Excel adds your title. 
3. Select Axis Title. Click on Axis Title. Place your cursor 

before the A in Axis. Hold down the Shift key while you 
use the right arrow key to highlight the words Axis 
Title. 

4. Type Sales. Excel labels the axis. 
5. Click anywhere on the chart to end your entry. 

Change the Style of a Chart 
 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 

3. Click the More buttons in the Chart Styles group. 
The chart styles appear. 

4. Click Style 42. Excel applies the style to your chart. 

 

Change the Size and Position of a Chart 
When you click a chart, handles appear on the right and left sides, the top and bottom, 
and the corners of the chart. You can drag the handles on the top and bottom of the 
chart to increase or decrease the height of the chart. You can drag the handles on the 
left and right sides to increase or decrease the width of the chart. You can drag the 
handles on the corners to increase or decrease the size of the chart proportionally. You 
can change the position of a chart by clicking on an unused area of the chart and 
dragging. 

Move a Chart to a Chart Sheet 
 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 
3. Click the Move Chart button in the Location group. The Move Chart dialog box 

appears. 
4. Click the New Sheet radio button. 
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5. Type Toy Sales to name the chart sheet. Excel creates a chart sheet named Toy 
Sales and places your chart on it. 

 
 
 

Change the Chart Type 
Any change you can make to a chart that is embedded in a worksheet, you can also 
make to a chart sheet. For example, you can change the chart type from a column chart 
to a bar chart. 

 
1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 
3. Click Change Chart Type in the Type group. The Chart Type dialog box appears. 
4. Click Bar. 
5. Click Clustered Horizontal Cylinder. 
6. Click OK. Excel changes your chart type. 

 
Filter in 

Filter your Excel data if you only want to display records that meet certain criteria. 
1. Click any single cell inside a data set. 

2. On the Data tab, in the Sort & Filter group, click Filter. 
 
 
 
 
 
 
 

 

3. You can see drop down arrow on the selected field/heading. 

4. Click on drop down arrow and check/uncheck your data which you want to saw. You 
can also arrange your data ascending or descending order. 

Freeze 
 

Whenever   you're   working   with   a    lot   of    data,  it    can   be    difficult    to 
compare information in your workbook. Fortunately, Excel includes several tools 
that make it easier to view content from different parts of your workbook at the 
same time, such as the ability to freeze panes and split your worksheet. 

 

To freeze rows: 
 

You may want to see certain rows or columns all the time in your 
worksheet, especially header cells. By freezing rows or columns in 
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place, you'll be able to scroll through your content while continuing to view 
the frozen cells. 

 
1. Select the row below the row(s) you want to freeze. In our example, we 

want to freeze rows 1 and 2, so we'll select row 3. 

2. Click the View tab on the Ribbon. 

3. Select the Freeze Panes command, then choose Freeze Panes from the 

drop-down menu. 

4. The rows will be frozen in place, as indicated by the gray line. You 

can scroll down the worksheet while continuing to view the frozen 

rows at the top. 

To freeze columns: 

1. Select the column to the right of the column(s) you want to freeze. In our 

example, we want to freeze column A, so we'll select column B. 

2. Click the View tab on the Ribbon. 

3. Select the Freeze Panes command, then choose Freeze Panes from the 

drop-down menu. 
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Print 

4. The 

column will be frozen in place, as indicated by the gray line. You 

can scroll across the worksheet while continuing to view the frozen 

column on the left. In our example, we've scrolled across to column E. 
 

To unfreeze rows or columns, click the Freeze Panes command, then 
select Unfreeze Panes from the drop-down menu. 

If you only need to freeze the top row (row 1) or first column (column 
A) in the worksheet, you can simply select Freeze Top Row or Freeze 
First Column from the drop-down menu. 
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1. Click the Print button. The Print dialog box appears. 
2. Click the down arrow next to the name field and select the printer to which you 

want to print. 
3. Click OK. Excel sends your worksheet to the printer. 
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DATA VALIDATION and CONDITIONAL FORMATTING  

• Data validation to allow / disallow certain types of data to be entered within a spreadsheet  

• Using Data Validation to choose a value for a cell from a dropdown list predefined with a list of data 

with a     defined name  

• Formatting certain cells to only accept a date value with parameters  

• Returning Error Messages if Data Validation is not passed for a particular cell value  

• Conditional Formatting may be used to highlight values in a particular column based on their values  

• Quickly identify items that need attention within a spreadsheet using the Conditional formatting 

tools within Excel  

This session will cover a number of functions in Excel that allow for better data entry and will 

show you how to quickly identify items within a spreadsheet that fit a certain criteria.  

Data Validation  

When creating a form in excel, or using fields to set criteria or parameters for a query, it may 

be important to limit the type of data a user us allowed to key into the field.   

The Data Validation function in Excel limits the user’s ability to fill in a field by setting criteria 

on the cell.  

On the toolbar, the Data Validation option is found under the DATA tab – Data Validation.  

 

Once Selected, you are presented with the options to set in the cell / range for the validation.  

This functionality ensures that the data entered in a cell matches the pre-defined criteria of the 

cell value.  

By default – Data Validation is set to “ANY VALUE” - this allows the user to enter anything into 

the cell.  

  

  

  



 

 

 

Whole Number:  

When selecting the option to allow WHOLE NUMBERS in a cell, you will have the option to 

put parameters on the range of allowable numbers.  This may be useful if you are tracking a 

percentage of completion entry on a spreadsheet.  

  

In this example – the data validation will allow any whole number between 1 and 100.  

  

When a cell value is entered that does not match the defined criteria, a warning message 

appears.  (More on this later)  

  
 

Decimal:  

This function is similar to the Whole Number function, but allows the user to enter a number 

with decimal places.  
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I have changed the setting here to only allow values between 1 and 10.  But the Criteria to 

allow Decimal will let me enter a number with unlimited decimal places.  

  

When using numeric based validation, an error will appear if a text based data is entered.  

  

  

Date:  

You may define a start date and an end date when entering in date fields in the validation 

criteria.  
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These settings will ensure that a valid date is entered between 01/01/11 and 12/31/11  

  

The following setting ensures that the date entered is greater than 01/01/11  

  

Time:  

Time based fields for data validation ensure that a time entered in a field will fall into the 

selected criteria.  
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An error will occur if the time entered is outside of the set criteria.  

  

Data Validated:  
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Text Length:  

Text Length is the first text-based validation field.  It basically limits the number of characters that a 

user is allowed to enter in a field.  

  

Data Validated:  

  

Data Entry error:  
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Custom:  

The CUSTOM function allows a great deal of flexibility on validating items based on a formula.  

  

In this example, we want to limit the value of the sum to $2,000.00 for the data entered in cells C5 – 

C9.  

• Select cells C5:C9 .  This is the first time we have selected a range of cells to allow 

data validation.  

• Choose Data - Data Validation   

• Choose Allow: Custom   

• For the formula, use SUM to total the values in the range $C$5:$C$9. The result must 

be less than or equal to $2,000.00:     =SUM($C$5:$C$9) <= 2000  

If the Sum of the selected cells exceeds the amount defined in the Formula, you will receive a 

validation error.  
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Data validation - Input Message:  

This tab will allow you to prompt the user for what type of data you are expecting to be entered 

in the field.  

In this example, we are prompting the user to enter a date between 01/01/11 and 12/31/11.  

Selecting the  

“Show input message when cell is selected” will open a box that lets the user know of the 

required data type.  

  

Data validation – Error Alert:  

You may override the standard alert that does not inform the user on what is expected be 

selecting the Error Alert tab.  In this example – we will STOP the process to prompt the user for 

what is an allowable value within the selected cell.  



202 

nsthagunna.com.np 
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If data is entered that does not pass the validation, your custom message will appear.    

  

You may also set the Error Alert to WARN the user that they are entering in an invalid value.  

  

The WARNING Error Alert will allow the user to continue even though the data does not pass the 

validation criteria.  Make sure this is the option you wish to choose as it subverts the validation you 

defined on the SETTINGS tab.  
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A third option is available when defining Error Alerts.  This message may be defined as 

INFORMATION only.   

  

In this example, when erroneous data is entered, the user will be prompted as follows:  

This option will allow the user to click OK and accept the entry even though it does not pass the 

criteria.  
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NOTE: These settings will be based on the needs of the individual form.  Special consideration 

should be placed on selecting any option other than STOP, as the INFORMATION and WARNING 

option will allow the user to enter a value that does not pass the validation.  

Data Validation –  List:  

The List option in Data Validation allows an easy method of entering values from a predefined list of 

items.  

The first thing to know about selecting the LIST option is that you must first define a NAED RANGE 

for the list of items being used.  

I have created two individual lists.  One is a query of my active jobs and the other is Months of the 

year.  

  

In order to use validation against a list, we must NAME the range.  This will create a reference that 

defined all of the values in a particular cell range.  

Start by highlighting the appropriate data range. In this example, I wish to select all of the values in 

column A, as this list will expand and/or contract as new jobs are added to the list.    
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Access the FORMULAS tab and select DEFINE NAME.  

  
If you have a column heading on the data set, the Named Range will assume that this is the value 

that is defined for the named range.  In this example JOB is the NAME of the data set and it refers 

to any and all values in column A.  

Click OK to save the range.  

http://www.nsthagunna.com.np/
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When selecting Column A, you will notice that the title in the upper left hand corner is now JOB.  

  

  

 We can now set validation for the range of values that we have selected.  
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The SOURCE will be the NAMED RANGE value preceded by the “=” sign.   

  

  

When the “In-Cell Dropdown” is selected, we have enabled a dropdown menu to select a value 

from the data set defined in the named Range.  

  

 Selecting a finite range of cells for a named range:  
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In the previous example, we selected an entire column for the LIST / NAMED RANGE.  In this 

example, we will define a named range for a specific set of cells.  

Select the Range of cells that contain the data set.  Since the data set does not contain a column 

heading, we will also have to set a name for the range.  In this example, it will be titled “MONTH”.  

   

Set the Data Validation on your cell to allow the SOURCE: =MONTH  

  

You now have a dropdown selection defined in the cell to choose a month.  
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CONDITIONAL FORMATTING  

Conditional Formatting is another function that will allow the user to set “alerts” based on values 

contained within cells.    

Basically, you will set criteria for the data set and then define the format of the cells.  

In this example, we will be looking at a data set that includes The Job numbers and their Original 

Contract Amount.  

  

We will define the following criteria for the Conditional formatting:  

• Contract Amount = 0 : Color the Cell Red  

• Contract Amount > $ 1,000,000 : Color the Cell Green with Yellow text  

 Contract amount < $ 1,000,000 : Color the Cell Yellow with Black 

text  

http://www.nsthagunna.com.np/
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It is important to think about the order that the criteria will be defined for the conditional formatting, 

as a value of 0.00 is also less than 1,000,000.  If you have problems with multiple formatting 

criteria, you may sequence the order in which the criteria is looked at.  

To enable conditional formatting, select the range of cells that should be referenced.  Access the 

HOME tab and select Conditional Formatting – NEW RULE.  

  

There are many options in the conditional formatting.  We will focus on the “Format Cells That 

Contain” option.  
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To create the first rule, we will select “format only cells with:”  

Cell Value equals 0  

  

Once the criteria is defined, select the FORMAT button to choose the behavior of the cell.  This 

criteria will be defined as a cell filled in with red.  
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Click OK to save the criteria.  

  
Highlight the entire column again and Select Conditional Formatting – NEW RULE again.  

Format these cells to fill with yellow.  
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OOPS: You will see that we trumped our last rule, now any value less than 1,000,000 will show as 

a cell filled with yellow.  

  

We can solve this situation by selecting Conditional Formatting – Manage Rules  
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The Conditional formatting should show the Cell Value = 0 FIRST, then Cell Value < 1,000,00 as a 

second criteria.  

 

Highlight the rule and click the UP arrow in the toolbar to rearrange the rules.  

   

With the hierarchy properly defined properly, we now have both rules in effect.  
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Our third rule will allow us to define the formatting for all values over $1,000,000.  

  

Again, highlight all of the data in the desired column and select conditional formatting – new rule.  

  

  
  

Formatting as follows:  

  

Fill the Cell GREEN        Color the text YELLOW  
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 Here are the results based on our rules:  

  

You may now use the Auto filter options to filter values based on their cell properties:  



218 

nsthagunna.com.np 

 

  

Formatting for the Top or Bottom Ranked Values:  

There are a number of predefined rules that you may use when searching for data.  

The TOP/BOTTOM rules are a good way to specify your top $ Contracts.  

Select conditional formatting – Top/Bottom Rules – Top 10 Items  

  

If you select a default from the dropdown, you will be able to select predefined formats from a list.  
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PivotTables  
PivotTables are a powerful tool in Excel that will allow you to quickly summarize, sort, filter, and 

analyze data. They can handle large amounts of data in lists and tables by organizing data, on the fly, 

different rows and columns. This is faster, and more flexible for analyzing you data, as you don't need 

to rely on formulas.   

For example, you could have a spreadsheet that contains information on salespeople, products sold, 

regions, items sold, etc. Using a PivotTable, you can quickly organize the data so different relationships 

are visible (e.g. Who is the top salesperson? What product has sold the most?).  

 

Note: When working with PivotTables, the data should contain your titles in a single row, and the table 

should not contain any empty cells.  

  

Creating PivotTables  
The following will show you how to create a PivotTable using the sample sales spreadsheet as an 

example:  

 

    

2. Under the Tables grouping, Click PivotTable.  

  

  

  
Figure 1 - Sample Sales Spreadsheet  

1.   In the  Ribbon , Click the  Insert  tab.  

  

  
Figure 2 - Insert Tab  
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3. The Create PivotTable window will appear. Excel will automatically select the data it thinks you 

want to use to create your PivotTable.  

  

 

Note: To select a different range from what Excel has suggested, Click the cell selection box and use the 

mouse to select a new range.  

  

4. Under Choose where you want the PivotTable report to be placed, select New Worksheet.  

  

 
Figure 5 - Create PivotTable on a New Worksheet  

  

5. Click OK.  

  

6. The PivotTable will be created in a new worksheet.  

  
Figure 3 - PivotTable  

  
Figure 4 - Create PivotTable Window  
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7. The PivotTable Fields will appear on the right side of the screen.  

  

 
Figure 7 - PivotTable Fields   

  

  
Figure 6 - New PivotTable Worksheet  
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Analyzing Data with PivotTables  
After creating your PivotTable, the PivotTable Fields list will display the data ranges that you selected, 

and four areas that will make up your PivotTable (Filters, Columns, Rows, and Values). You can quickly 

move fields in and out of these areas to view your data in different ways.   

  

For example, we want to use the PivotTable to analyze the data and determine how many sales a 

salesperson has made of each product.  

1. Drag-and-drop your fields into the filter, column, rows, and values boxes.  

a. Filters area fields are shown as top-level report filters above the PivotTable (See Error! R 

eference source not found.).  

b. Columns area fields are shown as Column Labels at the top of the PivotTable (See Error! R 

eference source not found.).  

c. Rows area fields are shown as Row Labels on the left side of the PivotTable (See Error! R 

eference source not found.).  

d. Values area fields are shown as summarized numeric values in the PivotTable (See Error! R 

eference source not found.).  
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Figure 8 - Select PivotTable Fields  
2. The PivotTable will change to show the fields in their respective locations, showing total sales for 

each sales person by product.  

  

 

Filtering the PivotTable  
The following shows how to filter information within a PivotTable:  

1. Next to a Field Header, click the drop-down arrow.  

  

 
Figure 10 - Drop-Down Button  

2. A Drop-down menu will appear with values for the field listed below.  

  

  
Figure 9 - PivotTable Results  
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3. Click the checkboxes to select/deselect values that you want to filter for.  

4. Click OK to apply your filter.  

5. A filter icon will appear next to the drop-down arrow to indicate a filter has been applied to the 

field.  

 

6. To remove the filter, click the drop-down arrow.  

  

  

    

7. The drop-down menu will appear. Click Clear Filter From to remove the filter.  

  

  
Figure 11 - Filter Values  

  

  
Figure 12 - Filter Applied  
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PivotCharts  
Similar to PivotTables, PivotCharts can be used to quickly summarize, sort, filter, and analyze large 

amounts of data, and display that data as a visual representation. After creating your PivotTable, you 

can create a PivotChart using a variety of available charts (e.g. Pie, Line, Bar) that uses the same field 

settings.   

  

Creating PivotCharts  
The following will show you how to create a PivotChart from an existing PivotTable:  

1. Highlight the data you want to use for your PivotChart.  

2. In the Ribbon, Click the Insert tab.  

 
Figure 14 - Insert Tab  

3. Under the Charts grouping, click PivotChart.  

  
Figure 13 - Clear Filter From  
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4. The Create PivotChart window appears to allow you to change the data range, choose where you 

want the PivotChart to be placed, and choose whether or not you want to analyze multiple 

tables. Make your selections and click OK. In this example, a new worksheet will be created.  

  

 

    

5. The PivotChart will be placed into your workbook on a new worksheet.  

  

  
Figure 15 - PivotChart  

  
Figure 16 - Create PivotChart Options  
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6. The PivotChart Fields will appear on the right side of the screen.  

  

 

Note: You can alter the information that is displayed the same way as with PivotTables. See Analyzing 

Data with PivotTables for more information.  

7. To change the chart type, click the chart and click the Change Chart Type in the Data grouping on 

the Design tab.  

  
Figure 17 - New PivotChart Worksheet  

  
Figure 18 - PivotChart Fields  
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8. Click a Chart Type (see Figure 20).  

9. Click the Chart Style you want to use (see Figure 20).  

10. Click OK to save the selection (see Figure 20).  

  

 

  

  

    

Filtering the PivotChart  
The following shows how to filter information within a PivotChart:  

1. Next to a Field Header, click the drop-down arrow.  

  

  
Figure 19 - Change Chart Type  

  
Figure 20 - New Chart Selection  
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2. A Drop-down menu will appear with values for the field listed below.  

  

 

3. Click the checkboxes to select/deselect values that you want to filter for.  

4. Click OK to apply your filter.  

  

5. A filter icon will appear next to the drop-down arrow to indicate a filter has been applied to the 

field.  

  

  
Figure 21 - Drop-Down Button  

  
Figure 22 - Filter Values  
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6. To remove the filter, Click the drop-down arrow.  

7. The drop-down menu will appear. click Clear Filter From to remove the filter.  

  

 
Figure 24 - Clear Filter From  

    
Using Slicers to Filter Data  
Slicers can provide greater control over your PivotTable or PivotChart when you are analyzing your data. 

Slicers work similar to filtering your information, but allows you to insert tables that you can use to 

  
Figure 23 - Filter Applied  
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quickly select values to filter/unfilter. They will show what is currently shown/not shown at a glance. 

Slicers can also be adjusted to change their size and color to make them more presentable.   

  

Inserting Slicers into your PivotTable or PivotChart  
The following explains how to insert Slicers into your PivotTable:  

1. Click within your PivotTable to select it.  

 

3. Under the Filters grouping, click Slicer.  

  

 

4. The Insert Slicers window will appear with a list of your available fields.  

  

 

5. Click the checkboxes next to the field(s) you want to create slicers for.  

6. Click OK.  

7. The slicers will be inserted into your spreadsheet.  

  

2.   In the  Ribbon , Click the  Insert  tab.  

  

  
Figure 25 - Insert Tab  

  
Figure 26  –  Slicer  

  
Figure 27 - Insert Slicers Window  
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8. Click and drag the slicers to reposition them as necessary.  

9. To apply a filter from one of the slicers, click one of the values.  

  

  
Figure 29 - Using a Slicer  

Note: To select multiple values, hold down the shift key while clicking your values.  

  

10. To remove values from your slicer, click the Clear Filter icon in the upper-right hand corner of 

the slicer.  

  

 
Figure 30 - Clear Filter from Slicer  

  
Figure 28 - Slicers Inserted  
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Additional Slicer Options  
When a Slicer is selected, the Slicer Tools – Options tab will be available in the Ribbon. From this tab, you 

can change the Slicer caption, style, and size of the buttons and window. The following explains how to 

access the Slicer Tools – Options tab:  

1. Click the Slicer.  

2. In the Ribbon, click the Slicer Tools – Options tab.  

 

3. Additional Slicer tools will be displayed. From here you can alter the slicer captions, styles, 

button, and window size.  

  

  
Figure 32 - Additional Slicer Tools  

  

Additional Help  
Our website: nsthagunna.com.np 

YouTube Channel: https://www.youtube.com/@nirajansth 

Facebook Page: https://www.facebook.com/nirajansth100 

  

  
Figure 31 - Slicer Tools - Options Tab  
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Some Excel Practice Questions: 

1.Datedif  

Details B3 C3  Age   

Name  Date of Birth Today  Year Month Day 

Nirajan 1/15/2057 2/28/2078  21 1 21 

Gita 3/5/2056 2/28/2078        

Raju 6/5/2073 2/28/2078        

Sita 3/1/2051 2/28/2078        

Barun 3/2/2051 2/28/2078        

Arun 3/3/2051 2/28/2078        

 

Age:  

Year: =DATEDIF(B3,C3,"Y") Month: =DATEDIF(B3,C3,"YM") 

Day:=DATEDIF(B3,C3,"MD") 

 

 

 

 

Details:=CONCATENATE(A3," ","is"," ",E3,"year"," ",F3," ","Month"," ",G3," ","Day") 

 

2. Index: 

SNO Products Sales (2076) Sales (2077)  Value Serial Number  

1 Keyboard 13038 6741  Earphone 6  

2 Mouse 3893 9070     

3 Monitor 885 14925  Value Row Number Column Number 

4 Printer 9981 7714  CPU 5 2 

5 CPU 10470 8238     

6 Earphone 9708 9995     

 

Value: =INDEX(B3:B8,G3) 

Value: =INDEX(A3:D8,G6,H6) 

Detials      

 Nirajan is 21year 1 Month 21 Day 

  

  

  

  

  

  



3. Match: 

 

4.  

 

 

 

 

 

 

 

 

 

 

5. 

 

 



6.  

7. 

 

8. PMT 

 

 



9. IPMT, PPMT 

 

 

IPMT:  

 

PPMT:  

10.  

11.

 

11.  

 



12. 

 

 

13.  

 

 

14.  

 

 

 

 

 

 

 

 

 

 


